MW5: Possible Fix for Mouse Bug in Co-op

The issue

When playing Co-op in Mechwarrior 5: Mercenaries, if you get a mission that starts from a dropship (rather than just spawning directly onto the map), you sometimes lose mouse control when it’s time to exit the dropship. You can still fire, and the mouse will work on the game menu, but you can no longer aim using the mouse.

What worked for me

As an Nvidia GPU user, pull up the Ansel overlay using ALT+F2, then close it again. Mouse control returns.

Speculation on root cause

I’ve noticed that when the bug is going to occur, I actually have mouse control while in the dropship itself (and can fire my weapons inside it, which you normally can’t do).

My theory based on that is there’s some kind of issue relating to mouse control being toggled (between on and off) rather than being explicitly set to on or off.

It could also be an issue with Ansel or some other software that might be interfering with what program “owns” the mouse. Since the fix is so easy and has had a 100% rate of success, I haven’t bothered to investigate further, and haven’t even tried disabling the Ansel overlay to see if that’s the issue.

Feedback

This seems to be an uncommon issue (I couldn’t find anyone else experiencing it specifically in MW5, just in some other games), so if you have it and this helps (or doesn’t help) please take a minute to leave a comment – especially for the latter if you find something that does!

5 Replies to “MW5: Possible Fix for Mouse Bug in Co-op”

  1. I have little control over crosshairs but I do get a main menu cursor that is messing up playing I have tried this and that…redownloaded but nothing works any guess now

    1. Interesting. This isn’t the same problem that I was having, since I was actually playing on Game Pass (MS Store), not EGS – but it should be helpful to some people at least. It also only occured for me in multiplayer (never in singleplayer across dozens of hours).

      edit: my copy was Game Pass (MS store) not EGS.

  2. TAKTOCM, the solution in the post you linked to worked for me! Thank you so much – a real lifesaver!! I had tried everything, mouse options, display options, clean installs of everything, Windows restore, etc. etc. etc. and dropping those files fixed it.

    FYI, I was getting this bug in campaign/story mode where the mouse pointer would always be visible, and soon after a mission started, the reticle would stop responding and the mouse would simply move around the screen, rendering the game nearly unplayable, For some reason, holding down a mouse button while moving it moved the reticle, but that is obviously a big problem when you fire with your mouse.

Leave a Reply to TAKTCOM Cancel reply

Your email address will not be published. Required fields are marked *

I accept the Privacy Policy

This site uses Akismet to reduce spam. Learn how your comment data is processed.